Platform RequirementsΒΆ

Colectica Portal requires the following components to be installed.

  1. Colectica Repository

  2. Microsoft .NET Framework 4.7.2 SDK or higher

    • Note, the SDK is different than the .NET runtime
  3. IIS 7.5+

  4. .NET Core Windows Server Hosting bundle

  5. Elasticsearch (optional)

  6. One of the following databases:

    • Microsoft SQL Server 2008 R2 or higher
    • Microsoft SQL Server Express 2008 R2 or higher
    • PostgreSQL version 9 or higher
    • Oracle 11g Release 2